Payment

Pay by credit card or bank transfer, then download your product.

Payments: Visa, MasterCard, Maestro, Amex, Discover, Paypal, Google Checkout, Avangate

100% Support

30 minutes free technical support.

Guarantee

30 day money-back guarantee.

 

Main Page


Pika Software Builder "Pika" is a software creation tool for Windows. Pika creates programs for Windows XP, Vista, 7 and 8. This wiki is the documentation and knowledge base for Pika users. Below is a list of Pika functions.

Contents

Overview

Prime Features

  • Add common windows (and non-windows) components to your programs like:

- Buttons

- Check boxes

- Radio buttons

- Text fields

- Drop down menus

- Tab menus

- Shockwave flash

- Media players

- Web Browsers

- Date selectors

  • Add Full System Tray functionality to your programs
  • Add Splash Screens to your programs
  • Program Form Shaping - shape your programs to any form
  • Create programs that download files from the internet
  • Create programs that send emails, even with attachments
  • Create programs that upload files to a server via FTP
  • Full screen support - make full screen applications
  • Choose from tons of templates to get you going

System Requirements

General requirements:

  • 400 MHz processor
  • 256MB of memory
  • 135MB of available disk space
  • Some features require a standard internet connection. Even a dialup connection will do.

Installation

Installing

To install Pika, follow these instructions:

1. Download the Pika setup file.

2. Open the setup file and click 'Next'.

3. Select the folder to install Pika to. The default folder is "Pika" in the program files folder.

4. Click 'Next' to start the installation.

5. Click on 'Finish' to finalize the installation.

Uninstalling

To uninstall Pika, follow these instructions:

1. Go to 'Start->All Programs->[Pika]->Uninstall Pika Software Builder'. Where [Pika] is the folder to which Pika was installed.

2. Confirm the uninstallation.

OR

1. Go to 'Start->Control Panel->Uninstall a program'.

2. Choose Pika and uninstall it.

FAQ (Frequently Asked Questions)

What is Pika?

Pika is a program that makes other programs. We call this a "software builder". What makes Pika different is that anyone can use it, unlike other software builders (known as "compilers") that need the user to know some programming language (like "C++, Fortran or Pascal").

With Pika, you can create Windows programs as the Pro's do without their knowledge.


Why Pika?

If you need custom software for your business, school, organization or yourself, but don't have the heavy programming skills required, then Pika is for you.

Sure, there are other alternatives like paying a freelancer hundreds of dollars or outsourcing a firm for thousands of dollars to do the job. But when you realize that you can do it yourself for a fraction of the cost, the decision is a no-brainer.


Where can I get Pika?

Pika is available for download from pikaonline.com.


Who uses Pika?

Pika's community is truly one of the most diverse. From internet cafe owners to managers, graphic designers and hobbyists.

Even programming gurus have found a need for Pika in their professions.


Who develops Pika?

Who better to develop a surfboard than a surfer? Pika is developed and maintained by people that actually need and use Pika. This means that people like you, who have no programming background, call the shots. These people are backed by a strong team of programmers that do the boring, but important stuff.


Where can I get help when building my programs?

We are always here to help. Take a look at Pika's documentation for the answers you need and if that's not enough, you can contact us for even more help.


What can I do with Pika?

You can create so many kinds of applications with Pika. From custom web browsers to contact forms to greeting interfaces, Pika has you covered.


Do I need Pika?

If you can't afford to have custom programs built for you and you don't have the advanced skills to build them yourself, then Pika is the solution for you. With nothing, but basic computer skills required, you can build your own programs with Pika.


How much does Pika cost?

At just $19.00, Pika's a steal.


I still have unanswered questions. What do I do?

Our doors are always open to your queries. Contact at pikaonline.com/contact

Keyboard Commands

Command / Description

Ctrl+Z / Undo

Ctrl+Y / Redo

Ctrl+X / Cut: Copy And Delete A Selected Component

Ctrl+C / Copy A Selected Component

Ctrl+V / Paste A Copied Component

Shift+Del / Delete The Selected Component(s)

Ctrl+A / Select All

Ctrl+D / Deselect All

Ctrl+N / Start A New Project

Ctrl+O / Open A Project

Ctrl+S / Save The Current Project

Ctrl+Alt+C / Save The Program

Ctrl+P / Print

Ctrl+Q / Quit Pika

Main Window

Main Window Components

When Pika is launched several components are available by default. These Include:

1. Toolbar panel

2. Menu bar

The menu bar, located right at the top of the Pika interface provides access to all of Pika's functions.

The following are the available menu items:

File

  • New Project
  • Open Project
  • Reopen Project
  • Open Template
  • Save Project
  • Save Project As
  • Save Program
  • Save Program As
  • Print
  • Exit

Edit

  • Undo
  • Redo
  • Cut
  • Copy
  • Paste
  • Delete
  • Select All
  • Deselect All

View

  • Program Edit Form
  • Background Edit Window
  • Functions Edit Window
  • Title Edit Window
  • Icon Edit Window
  • Enable Main Menu
  • Splash Screen Edit Window

Program

  • Run Program
  • Edit Title
  • Edit Icon
  • Edit Background
  • Edit Splash Screen
  • Edit Main Menu
  • Edit Functions
  • Change Window Size
  • Change Border

Tools

  • Button
  • Image
  • Label
  • Text Field
  • Text Box
  • Check Box
  • Radio Button Group
  • Check List
  • Drop Down Menu
  • Number Selector
  • Tab Menu
  • Text List
  • Date Selector
  • Web Browser
  • Media Player
  • Flash
  • Image Button

Help

  • Help Contents
  • Online Help
  • Pika FAQs
  • Templates
  • Check for Updates
  • Buy Pika
  • Register Pika
  • Pika Online
  • About Pika

3. Component list

Component List

Menu Bar

Toolbar

The toolbar offers easy access to the most common functions.

Functions in the toolbar include:

1. New Project

2. Open A Project

3. Save Project

4. Save Program

5. Run Program

6. Help

Menu Options

File

New Project

This command will close the current project and start a new one.

Shortcut: Ctrl - N

Open Project

This command will close the current project and open a new one from the local disk or removable storage device.

Reopen Project

This command will close the current project and open a new one from a list of recently opened projects.

The source of the recently opened project(s) can be from the local disk or removable storage device.

Open Template

This command opens the template library.

In Pika Light Edition, this command open the online template library.

Save Project

This command will save the current project.

If the project has not been saved before, then a dialog will be opened for the user to select a location to save the project to.

Save Project As

This command will save the current project to a specified locations.

A dialog will be opened for the user to select a location to save the project to.

Save Program

This command will save the current project's program. The program's final executable file (.exe) will be saved to the specified location.

If the program has not been saved before, then a dialog will be opened for the user to select a location to save the program to.

Save Program As

This command will save the current project's program in specified location. The program's final executable file (.exe) will be saved.

A dialog will be opened for the user to select a location to save the program to.

Print

This command will print the program's current form.

Shortcut: Ctrl - P

Exit

This command quits Pika.

If the current program's progress has not been saved then the user will be prompted to save the project.

Edit

Undo

This command will undo the last action performed.

Shortcut: Ctrl - Z

Redo

This command will redo the last undone action.

Shortcut: Ctrl - Y

Cut

This command will copy and delete the currently selected component.

Shortcut: Ctrl - X

Copy

This command will copy the currently selected component.

Shortcut: Ctrl - C

Paste

This command will place any copied components onto the form.

Shortcut: Ctrl - V

Delete

This command will delete the currently selected component from the program's form.

Shortcut: Shift - Del

Select All

This command will select all components on the form.

Shortcut: Ctrl - A

Deselect All

This command will deselect any selected components on the program's form.

Shortcut: Ctrl - D

View

Program Edit Form

This is panel is located under the 'Properties' tab.

This form sets the program's main properties.

Background Edit Window

The background property allows you to set the background of the program.

The three main options are:

1. No Background - or plain background

2. Color Background

3. Image Background: Use an image for a background

Functions Edit Window

Title Edit Window

The title property changes the program's title.

Icon Edit Window

The icon property changes the program's internal and external icon.

Enable Main Menu

The main menu property allows the user to add, remove and change menu items.

The property also allows for the complete disabling of the main menu.

Splash Screen Edit Window

With the splash screen property, you can enable or disable the use of a splash screen.

The property is also used to set the splash screen's picture and display time.

Program

Run Program

This command will run the program that is being built.

The program will be displayed in exactly the same way it will be when saved and run as a stand alone program.

Edit Title

The title property changes the program's title.

Edit Icon

The icon property changes the program's internal and external icon.

Edit Background

The background property allows you to set the background of the program.

The three main options are:

1. No Background - or plain background

2. Color Background

3. Image Background: Use an image for a background

Edit Splash Screen

With the splash screen property, you can enable or disable the use of a splash screen.

The property is also used to set the splash screen's picture and display time.

Edit Main Menu

The main menu property allows the user to add, remove and change menu items.

The property also allows for the complete disabling of the main menu.

Edit Functions

Change Window Size

Change Border

The border type property sets the program's border.

The options to choose from are:

1. No Border

2. Tool Box Border

3. Close Button Only

4. All Buttons

Tools

The component list is a list of items that you can add to your program.

The list can be accessed on the main interface, under "Add Components" tab of from the menu, under "Tools".

The following is the full component list:

Button

The button component allows you to add buttons to your program. To add a button, go to "Tools->Add a Button" and place it anywhere on your program's form.

How to make a button do something when it is clicked.

1. Select the button by clicking on it. A window should popup.

2. Under the "Functions" group, select "Clicks On This Button".

3. Click on "New Function" and set a function.

Image

The image component allows you to add pictures to your program.

To add an image, go to "Tools->Add an Image" and place it anywhere on your program's form.

Notes

An image behaves largely like a button which means it can be clicked and have the mouse moved over it. Click here to see the button component's documentation.

Label

The label component allows you to add text to your program.

To add a label, go to "Tools->Add a Label" and place it anywhere on your program's form.

Notes

A label behaves largely like a button which means it can be clicked and have the mouse moved over it. Click here to see the button component's documentation.

Text Field

The text field component allows users to add text to your program. To add a text field, go to "Tools->Add a Text Field" and place it anywhere on your program's form.

Text Field example

1. Add a text field menu and a button to your program's form.

2. Select the button by clicking on it. A window should popup.

3. Under the "Functions" group, select "Clicks On This Button".

4. Click on "New Function" and select the function "Display A Message".

5. On the right, click on "Set The Message To Display".

6. Select the tab "Get Message From A Component".

7. Select the component "Text Field 1".

8. Click "OK" through everything and run the program.

Now when you click on the button, the contents of the Text Field will be displayed.

Text Box

The text box component allows users to add text to your program. To add a text box, go to "Tools->Add a Text Box" and place it anywhere on your program's form.

Text Box example

1. Add a text box menu and a button to your program's form.

2. Select the button by clicking on it. A window should popup.

3. Under the "Functions" group, select "Clicks On This Button".

4. Click on "New Function" and select the function "Display A Message".

5. On the right, click on "Set The Message To Display".

6. Select the tab "Get Message From A Component".

7. Select the component "Text Box 1".

8. Click "OK" through everything and run the program.

Now when you click on the button, the contents of the Text Box will be displayed.

Check Box

A check box allows a user to select or unselect an option. To add a check box, go to "Tools->Add a Check Box" and place it anywhere on your program's form.

An example of using a check box:

1. Place a check box and a button on the program's form.

2. Select the button by clicking on it.

2. Under the "Functions" group, select "Clicks On This Button".

3. Click on "New Function".

4. Select "Display A Message" and set the message "Hello".

5. Check "Use A Condition For Performing This Job".

6. Under "Only Perform This Job If", select "This Check Box Is Checked: Check Box 1".

7. Click "OK" and run the program.

Now when you click on the button, the message "Hello" will only be displayed when the check box is checked.

Radio Button Group

The radio button group component allows users to select one item in a list. To add a radio button group, go to "Tools->Add a Radio Button Group" and place it anywhere on your program's form.

Radio Button Group example

1. Add a radio button group and a button to your program's form.

2. Select the button by clicking on it.

3. Under the "Functions" group, select "Clicks On This Button".

4. Click on "New Function".

5. Select "Display A Message" and set the message "Hello".

6. Check "Use A Condition For Performing This Job".

7. Under "Only Perform This Job If", select "In Check List 1, There's a Checked Item That".

8. Enter the text "Option 1" for the field "Includes The Text".

9. Click "OK" and run the program.

Now when you click on the button, the message "Hello" will only be displayed when the item "Option 1" is checked.

Check List

A check list allows a user to select or deselect multiple options. To add a check list, go to "Tools->Add a Check List" and place it anywhere on your program's form.

An example of using a check list

1. Place a check list and a button on the program's form.

2. Select the button by clicking on it.

3. Under the "Functions" group, select "Clicks On This Button".

4. Click on "New Function".

5. Select "Display A Message" and set the message "Hello".

6. Check "Use A Condition For Performing This Job".

7. Under "Only Perform This Job If", select "In Check List 1, There's a Checked Item That".

8. Enter the text "Idea 1" for the field "Includes The Text".

9. Click "OK" and run the program.

Now when you click on the button, the message "Hello" will only be displayed when the item "Idea 1" is checked.

Drop Down Menu

The drop down menu component allows users to select one item in a list. To add a drop down menu, go to "Tools->Add a Drop Down Menu" and place it anywhere on your program's form.

Drop Down Menu example

1. Add a drop down menu and a button to your program's form.

2. Select the button by clicking on it. A window should popup.

3. Under the "Functions" group, select "Clicks On This Button".

4. Click on "New Function" and select the function "Display A Message".

5. On the right, click on "Set The Message To Display".

6. Select the tab "Get Message From A Component".

7. Select the component "Drop Down Menu 1".

8. Click "OK" through everything and run the program.

Now when you click on the button, the selected item in the Drop Down Menu will be displayed.

Number Selector

The number selector component allows you to select and use numbers in your program. To add a button, go to "Tools->Add a Number Selector" and place it anywhere on your program's form.

Number Selector example

1. Add a number selector and a button to your program's form.

2. Select the button by clicking on it.

3. Under the "Functions" group, select "Clicks On This Button".

4. Click on "New Function".

5. Select "Display A Message" and set the message "Hello".

6. Check "Use A Condition For Performing This Job".

7. Under "Only Perform This Job If", select "The Number In The Number Field...".

8. Enter the number "3" for the field "Is Equal To".

9. Click "OK" and run the program.

Now when you click on the button, the message "Hello" will only be displayed when the Number Field's value is 3.

Tab Menu

The tab menu component helps you manage other components in your program.

To add a button, go to "Tools->Add a Tab Menu" and place it anywhere on your program's form.

How to make a tab menu do something when a new page is selected.

1. Select the tab menu by clicking on it. A window should popup.

2. Under the "Functions" group, select "Selects A Different Tab".

3. Click on "New Function" and set a function.

Text List

The text list component allows users to select one item in a list. To add a text list, go to "Tools->Add a Text List" and place it anywhere on your program's form.

Text List example

1. Add a text list and a button to your program's form.

2. Select the button by clicking on it. A window should popup.

3. Under the "Functions" group, select "Clicks On This Button".

4. Click on "New Function" and select the function "Display A Message".

5. On the right, click on "Set The Message To Display".

6. Select the tab "Get Message From A Component".

7. Select the component "Text List 1".

8. Click "OK" through everything and run the program.

Now when you click on the button, the selected item in the Text List will be displayed.

Date Selector

The date selector component allows users to select and use dates. To add a date selector, go to "Tools->Add a Date Selector" and place it anywhere on your program's form.

Date selector example:

1. Add a date selector and a button to your program's form.

2. Select the button by clicking on it. A window should popup.

3. Under the "Functions" group, select "Clicks On This Button".

4. Click on "New Function" and select the function "Save Data To File".

5. Set the destination filename and under "Data To Save", add the text "Date Selector1".

6. Click "OK" through everything and run the program.

Now when you click on the button, the selected date will be saved to the specified file.

Web Browser

The web browser component allows you to display web pages in your program.

To add a web browser, go to "Tools->Add a Web Browser" and place it anywhere on your program's form.

How to load a new web page in a web browser.

1. Add a web browser and a button to your program's form.

2. Select the button by clicking on it. A window should popup.

3. Under the "Functions" group, select "Clicks On This Button".

4. Click on "New Function" and select the function "Open A Web Page In The Web Browser 1".

5. On the right, click on "Set The URL Of The Web Page To Open".

6. Enter the url to open.

7. Click "OK" through everything and run the program.

Now when you click on the button, the web browser will load the url specified.

Media Player

The media player component allows your program to play video and audio.

The media player component can play a variety of formats including mp3, flv, mpg, wmv, m4v, avi and so on.

To add a media player, go to "Tools->Add a Media Player" and place it anywhere on your program's form.

Notes

A media player's video display interface behaves like a button which means it can be clicked and have the mouse moved over it. Click here to see the button component's documentation.

Flash

The flash component allows you to add '.swf' flash animations to your program.

To add a flash item, go to "Tools->Add a Flash Player" and place it anywhere on your program's form.

Image Button

The image button component allows you to add buttons to your program.

To add an image button, go to "Tools->Add an Image Button" and place it anywhere on your program's form.

How to make an image button do something when it is clicked.

1. Select the button by clicking on it. A window should popup.

2. Under the "Functions" group, select "Clicks On This Button".

3. Click on "New Function" and set a function.

Help

Help Contents

The help button points to this documentation.

Components Tab

The component list is a list of items that you can add to your program.

The list can be accessed on the main interface, under "Add Components" tab of from the menu, under "Tools".

The following is the full component list:

Button

The button component allows you to add buttons to your program. To add a button, go to "Tools->Add a Button" and place it anywhere on your program's form.

How to make a button do something when it is clicked.

1. Select the button by clicking on it. A window should popup.

2. Under the "Functions" group, select "Clicks On This Button".

3. Click on "New Function" and set a function.

Image

The image component allows you to add pictures to your program.

To add an image, go to "Tools->Add an Image" and place it anywhere on your program's form.

Notes

An image behaves largely like a button which means it can be clicked and have the mouse moved over it. Click here to see the button component's documentation.

Label

The label component allows you to add text to your program.

To add a label, go to "Tools->Add a Label" and place it anywhere on your program's form.

Notes

A label behaves largely like a button which means it can be clicked and have the mouse moved over it. Click here to see the button component's documentation.

Text Field

The text field component allows users to add text to your program. To add a text field, go to "Tools->Add a Text Field" and place it anywhere on your program's form.

Text Field example

1. Add a text field menu and a button to your program's form.

2. Select the button by clicking on it. A window should popup.

3. Under the "Functions" group, select "Clicks On This Button".

4. Click on "New Function" and select the function "Display A Message".

5. On the right, click on "Set The Message To Display".

6. Select the tab "Get Message From A Component".

7. Select the component "Text Field 1".

8. Click "OK" through everything and run the program.

Now when you click on the button, the contents of the Text Field will be displayed.

Text Box

The text box component allows users to add text to your program. To add a text box, go to "Tools->Add a Text Box" and place it anywhere on your program's form.

Text Box example

1. Add a text box menu and a button to your program's form.

2. Select the button by clicking on it. A window should popup.

3. Under the "Functions" group, select "Clicks On This Button".

4. Click on "New Function" and select the function "Display A Message".

5. On the right, click on "Set The Message To Display".

6. Select the tab "Get Message From A Component".

7. Select the component "Text Box 1".

8. Click "OK" through everything and run the program.

Now when you click on the button, the contents of the Text Box will be displayed.

Check Box

A check box allows a user to select or deselect an option. To add a check box, go to "Tools->Add a Check Box" and place it anywhere on your program's form.

An example of using a check box:

1. Place a check box and a button on the program's form.

2. Select the button by clicking on it.

2. Under the "Functions" group, select "Clicks On This Button".

3. Click on "New Function".

4. Select "Display A Message" and set the message "Hello".

5. Check "Use A Condition For Performing This Job".

6. Under "Only Perform This Job If", select "This Check Box Is Checked: Check Box 1".

7. Click "OK" and run the program.

Now when you click on the button, the message "Hello" will only be displayed when the check box is checked.

Radio Button Group

The radio button group component allows users to select one item in a list. To add a radio button group, go to "Tools->Add a Radio Button Group" and place it anywhere on your program's form.

Radio Button Group example

1. Add a radio button group and a button to your program's form.

2. Select the button by clicking on it.

3. Under the "Functions" group, select "Clicks On This Button".

4. Click on "New Function".

5. Select "Display A Message" and set the message "Hello".

6. Check "Use A Condition For Performing This Job".

7. Under "Only Perform This Job If", select "In Check List 1, There's a Checked Item That".

8. Enter the text "Option 1" for the field "Includes The Text".

9. Click "OK" and run the program.

Now when you click on the button, the message "Hello" will only be displayed when the item "Option 1" is checked.

Check List

A check list allows a user to select or deselect multiple options. To add a check list, go to "Tools->Add a Check List" and place it anywhere on your program's form.

An example of using a check list

1. Place a check list and a button on the program's form.

2. Select the button by clicking on it.

3. Under the "Functions" group, select "Clicks On This Button".

4. Click on "New Function".

5. Select "Display A Message" and set the message "Hello".

6. Check "Use A Condition For Performing This Job".

7. Under "Only Perform This Job If", select "In Check List 1, There's a Checked Item That".

8. Enter the text "Idea 1" for the field "Includes The Text".

9. Click "OK" and run the program.

Now when you click on the button, the message "Hello" will only be displayed when the item "Idea 1" is checked.

Drop Down Menu

The drop down menu component allows users to select one item in a list. To add a drop down menu, go to "Tools->Add a Drop Down Menu" and place it anywhere on your program's form.

Drop Down Menu example

1. Add a drop down menu and a button to your program's form.

2. Select the button by clicking on it. A window should popup.

3. Under the "Functions" group, select "Clicks On This Button".

4. Click on "New Function" and select the function "Display A Message".

5. On the right, click on "Set The Message To Display".

6. Select the tab "Get Message From A Component".

7. Select the component "Drop Down Menu 1".

8. Click "OK" through everything and run the program.

Now when you click on the button, the selected item in the Drop Down Menu will be displayed.

Number Selector

The number selector component allows you to select and use numbers in your program. To add a button, go to "Tools->Add a Number Selector" and place it anywhere on your program's form.

Number Selector example

1. Add a number selector and a button to your program's form.

2. Select the button by clicking on it.

2. Under the "Functions" group, select "Clicks On This Button".

3. Click on "New Function".

4. Select "Display A Message" and set the message "Hello".

5. Check "Use A Condition For Performing This Job".

6. Under "Only Perform This Job If", select "The Number In The Number Field...".

7. Enter the number "3" for the field "Is Equal To".

8. Click "OK" and run the program.

Now when you click on the button, the message "Hello" will only be displayed when the Number Field's value is 3.

Tab Menu

The tab menu component helps you manage other components in your program.

To add a button, go to "Tools->Add a Tab Menu" and place it anywhere on your program's form.

How to make a tab menu do something when a new page is selected.

1. Select the tab menu by clicking on it. A window should popup.

2. Under the "Functions" group, select "Selects A Different Tab".

3. Click on "New Function" and set a function.

Text List

The text list component allows users to select one item in a list. To add a text list, go to "Tools->Add a Text List" and place it anywhere on your program's form.

Text List example

1. Add a text list and a button to your program's form.

2. Select the button by clicking on it. A window should popup.

3. Under the "Functions" group, select "Clicks On This Button".

4. Click on "New Function" and select the function "Display A Message".

5. On the right, click on "Set The Message To Display".

6. Select the tab "Get Message From A Component".

7. Select the component "Text List 1".

8. Click "OK" through everything and run the program.

Now when you click on the button, the selected item in the Text List will be displayed.

Date Selector

The date selector component allows users to select and use dates. To add a date selector, go to "Tools->Add a Date Selector" and place it anywhere on your program's form.

Date selector example:

1. Add a date selector and a button to your program's form.

2. Select the button by clicking on it. A window should popup.

3. Under the "Functions" group, select "Clicks On This Button".

4. Click on "New Function" and select the function "Save Data To File".

5. Set the destination filename and under "Data To Save", add the text "Date Selector1".

6. Click "OK" through everything and run the program.

Now when you click on the button, the selected date will be saved to the specified file.

Web Browser

The web browser component allows you to display web pages in your program.

To add a web browser, go to "Tools->Add a Web Browser" and place it anywhere on your program's form.

How to load a new web page in a web browser.

1. Add a web browser and a button to your program's form.

2. Select the button by clicking on it. A window should popup.

3. Under the "Functions" group, select "Clicks On This Button".

4. Click on "New Function" and select the function "Open A Web Page In The Web Browser 1".

5. On the right, click on "Set The URL Of The Web Page To Open".

6. Enter the url to open.

7. Click "OK" through everything and run the program.

Now when you click on the button, the web browser will load the url specified.

Media Player

The media player component allows your program to play video and audio.

The media player component can play a variety of formats including mp3, flv, mpg, wmv, m4v, avi and so on.

To add a media player, go to "Tools->Add a Media Player" and place it anywhere on your program's form.

Notes

A media player's video display interface behaves like a button which means it can be clicked and have the mouse moved over it. Click here to see the button component's documentation.

Flash

The flash component allows you to add '.swf' flash animations to your program.

To add a flash item, go to "Tools->Add a Flash Player" and place it anywhere on your program's form.

Image Button

The image button component allows you to add buttons to your program.

To add an image button, go to "Tools->Add an Image Button" and place it anywhere on your program's form.

How to make an image button do something when it is clicked.

1. Select the button by clicking on it. A window should popup.

2. Under the "Functions" group, select "Clicks On This Button".

3. Click on "New Function" and set a function.

Properties Tab

Border Type

The border type property sets the program's border.

The options to choose from are:

1. No Border

2. Tool Box Border

3. Close Button Only

4. All Buttons

Default Window Size

Background

The background property allows you to set the background of the program.

The three main options are:

1. No Background - or plain background

2. Color Background

3. Image Background: Use an image for a background

Functions

If you want your program to do something when opens, closes or is resized then the Functions property should be used.

Title

The title property changes the program's title.

Splash Screen

With the splash screen property, you can enable or disable the use of a splash screen.

The property is also used to set the splash screen's picture and display time.

Icon

The icon property changes the program's internal and external icon.

Enable/Disable Main Menu

The main menu property allows the user to add, remove and change menu items.

The property also allows for the complete disabling of the main menu.

Timer Tab

Number Of Milliseconds To Wait Before Each Cycle

This property determines how many times the list of jobs get performed in a second.

If, for example, the value is set to 1000 (milliseconds) then the jobs will be performed once every second.

Keep in mind that the value is always measured in milliseconds.

List Of Jobs To Perform Each Cycle

This property determines what the program does for every interval.

It's best to keep the jobs in this list light because the program will keep trying to perform the jobs over and over again each interval even if the jobs of the previous interval had not been finished.

System Tray Tab

Buttons To Show When The Icon Is Right Clicked

When there's a system tray icon, the user can right click the icon.

This property determines the buttons that are shown when the user right clicks the program's system tray icon.

Jobs To Perform When The User Clicks On The Icon

When there's a system tray icon, the user can click on the icon.

This property determines what the program does when the user clicks on the program's system tray icon.

Toolbar Panel

The toolbar offers easy access to the most common functions.

Functions in the toolbar include:

1. New Project

2. Open A Project

3. Save Project

4. Save Program

5. Run Program

6. Help

New Project

This command will close the current project and start a new one.

Shortcut: Ctrl - N

Open Project

This command will close the current project and open a new one from the local disk or removable storage device.

Save Project

This command will save the current project.

If the project has not been saved before, then a dialog will be opened for the user to select a location to save the project to.

Save Program

This command will save the current project's program. The program's final executable file (.exe) will be saved to the specified location.

If the program has not been saved before, then a dialog will be opened for the user to select a location to save the program to.

Run Program

This command will run the program that is being built.

The program will be displayed in exactly the same way it will be when saved and run as a stand alone program.

Help

The help button points to this documentation.

Retrieved from ""